The issue of CRM and Website latency, and images not loading, has been resolved.
Posted Dec 03, 2024 - 17:08 UTC
Update
We are continuing to investigate this issue.
Posted Dec 03, 2024 - 17:07 UTC
Investigating
Multiple clients have reported experiencing latency issues with both the CRM and their websites. Additionally, images are failing to load across affected platforms. Lofty engineers and investing the issue.