CRM server error
Incident Report for Lofty
Resolved
This incident has been resolved.
Posted Oct 27, 2022 - 13:47 UTC
Investigating
We are currently repairing an online server error that may prevent the CRM from being used.
Posted Oct 27, 2022 - 13:14 UTC
This incident affected: Lofty.