The issue impacting Lofty CRM and Lofty websites has been resolved, and services are now operating normally.
If you continue to experience any issues, please contact Support.
Posted Dec 15, 2025 - 18:50 UTC
Identified
The issue has been identified; however, Lofty CRM and Lofty websites remain unstable. Our team is actively working on a fix.
Posted Dec 15, 2025 - 17:54 UTC
Investigating
We are investigating an issue causing Lofty CRM to display Service Unavailable errors and Lofty websites to appear down. The team is actively working on a resolution.