unable to access CRM using Safari Browser
Incident Report for Lofty
Resolved
This issue has been resolved.
Posted Apr 17, 2023 - 17:57 UTC
Investigating
Clients using the Safari browser are experiencing a blank page when attempting to log into Chime.
Posted Apr 17, 2023 - 17:42 UTC
This incident affected: Lofty.